Your browser does not meet the minimum qualifications as required by the FPCS Online Office Application.
You must have a generation 5 or greater browser and can not use Internet Explorer 5.x on a mac.

Download Firefox

Your browser is reporting the following:
CCBot/2.0 (http://commoncrawl.org/faq/)